+ Reply to Thread
Results 1 to 9 of 9

Thread: Next and Previous Links on Front/Blog Pages

  1. #1
    Premium Gold
    Join Date
    Apr 2012
    Posts
    17

    Next and Previous Links on Front/Blog Pages

    Hey. So this actually seems to be an issue.

    Testing in the most recent versions of all 4 major browsers (Chrome, IE, Firefox, Safari), I/users encounter an issue where the Next and Previous links show as links (mouseovers reveal the target url, etc.), but clicking on them does nothing. You can click on the page numbers, and they work. I've searched pretty thoroughly on this topic and found something that seemed like the same issue with the Deep Blue theme, but it didn't give any fix information.

    Any insight would be appreciated.

    http://www.ishorrible.com

    Thanks!

  2. #2
    Administrator
    Join Date
    Oct 2011
    Posts
    1,478
    I think some java script is blocking it by targeting the class of the link, try to disable some of the plugins to find the cause of the problem, first time I hear of such a problem so I'm pretty much sure it's some sort of a java script hack.
    I'm the Admin here to help you out, Every time you post something make sure to include your website URL!

  3. #3
    Premium Gold
    Join Date
    Apr 2012
    Posts
    17
    Thanks for the reply.

    The only java I'm running on the site is for the slideshow. Also, I've already deactivated all of the plugins, and I'm still running into the same issue.

    In which php file do you call the class for these links?
    Last edited by chrisro; 04-29-2012 at 06:34 AM.

  4. #4
    Premium Gold
    Join Date
    Apr 2012
    Posts
    17
    So it's the slideshow.

    Switching back to flash, the link works.

    I don't want to use the flash slideshow, so what would you recommend?

    EDIT: And indeed the java for the slideshow is blocking those link classes...

    <script language="javascript" type="text/javascript">
    jQuery(document).ready(function()
    {
    jQuery('.slides').cycle({
    fx : '<?php mframe_option( 'slider-animation', 1 ); ?>',
    speed : <?php echo mframe_option( 'slider-speed' ) * 1000; ?>,
    timeout : <?php echo mframe_option( 'slider-timeout' ) * 1000; ?>,
    next : '.next',
    prev : '.prev',
    pager : '.controls',
    pause : <?php mframe_option( 'slider-hover-pause', 1 ); ?>,
    randomizeEffects: false
    });
    });
    </script>

    "next" and "prev" are what seem to be the problems -- I comment them out and the page links become functional. I'm trying out some edits to see what I can make work.
    Last edited by chrisro; 04-29-2012 at 11:02 PM.

  5. #5
    Premium Gold
    Join Date
    Apr 2012
    Posts
    17
    Yeah... Just sharing this because I could have figured this out a lot sooner had I zoomed out the page.

    Clicking on the Next and Previous links will actually advance/reverse the slides in the slide show.

    Admin, any thoughts on a good fix for this? I've fiddled, but nothing works completely.

  6. #6
    Administrator
    Join Date
    Oct 2011
    Posts
    1,478
    Yea I see that now, you need to change the classes, not remove them.

    The first change is in the code you provided:

    Change to, i.e:
    Code:
    next	: '.next2',
    prev	: '.prev2',
    The 2nd change is in same file:
    http://themes.svn.wordpress.org/famo...eme/slider.php

    Code:
    <a href="#" class="prev"></a><a href="#" class="next"></a>
    change to:
    Code:
    <a href="#" class="prev2"></a><a href="#" class="next2"></a>
    That should work.
    I'm the Admin here to help you out, Every time you post something make sure to include your website URL!

  7. #7
    Premium Gold
    Join Date
    Apr 2012
    Posts
    17
    Thanks for replying.

    I had tried that, but while the pagination links now work, it actually removes the prev-next arrows on the slider completely. I've made the change you suggested on my site and left it so you can take a look.

    http://www.ishorrible.com

  8. #8
    Administrator
    Join Date
    Oct 2011
    Posts
    1,478
    Right, I forgot something.

    Try this:

    Code:
    <a href="#" class="prev prev2"></a><a href="#" class="next next2"></a>
    Should work.
    I'm the Admin here to help you out, Every time you post something make sure to include your website URL!

  9. #9
    Premium Gold
    Join Date
    Apr 2012
    Posts
    17
    Perfect! Thank you!

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts